Welcome to the Pandawill Forum | Community for China Products Discussion.
Page 1 of 3 123 LastLast
Results 1 to 10 of 21
  1. #1

    Wopad M12 = Arnova 9 G2? Possible Android 4 ICS ROM

    Not sure about it, but it seems the Archos Arnova 9 G2 is exactly the same device as the Aoson Wopad M12.

    Take a look at it:
    http://arnovatech.com/products/g2/ar...try=cz&lang=en

    Well, it seems Arnova has released an Android 4.0 ICS ROM on a new model named Arnova 9 G2i (ICS) and it's been reported to work on the Arnova 9 G2.
    http://www.arctablet.com/blog/featur...-sandwich-ics/

    And, the ICS ROM has been dumped by some people on an Italian forum.
    http://www.androidiani.com/forum/arc...ml#post1550856

    Here is the URL to download the Android 4.0 ROM:
    https://rapidshare.com/files/3767413...0.3_romdump.7z

    And they've started working to root and customize this ROM.

    I have not tested it as the M12 is not my own device (it's shared for all the family), but maybe someone can test the ROM on the M12 and report if it works.

  2. #2
    Panda Member
    Join Date
    Nov 2011
    Location
    Southampton, United Kingdom
    Posts
    64
    I do not think that it is the same one. It looks to me like there is an extra button on the side.

    I had a quick look through the specifications and it looked pretty damn close but I think that the wi-fi is not as good on the G2.

  3. #3
    I believe I will try to flash the ROM after doing a backup of my tablet and ensuring the image fits the system partition.

    AFAIK, if it doesn't work, I think I will be able to reflash the previous ROM, as the boot partition is not flashed when you update the system partition.

  4. #4
    I have an Aoson M12 8GB and flashed the firmware from here http://www.arctablet.com/blog/forum/...h-google-play/

    the good points...

    I didn't brick it
    It booted with a large Arnova logo, 1st boot take a while as usual. A screen calibration runs, then I noticed the auto rotate, the screen is upside down
    Location/language wizzard runs.
    Wifi part of wizzard, can't turn on wifi

    OK, we're in ICS, model number AN9G2I, android version 4.0.3, kernel 3.0.8+, build number RK2918_ANDROID4.0.3-ARNOVA-V2.08.00-2012-4-19-18:33
    BUT no wifi and no sound.
    I switched screen auto rotate off in display settings.
    What works?
    Camera app runs ok, can select front or back camera ok.
    Found my SD card ok
    Connected with USB to my win7 x64 pc, found an 'AN9G2I' portable device, drivers installed automatically.

    I'll try flashing a second time...

    no joy, same as 1st time, I've restored Astroknights xmas firmware
    Last edited by dougie; 05-23-2012 at 02:03 PM. Reason: update

  5. #5
    Nice! Thanks a lot for trying it!

    Well, it's a good start in case the Android 4.0 ROM for the M12 promised at the www.99pad.com forums isn't finally released.

    The autorotation should be easily fixable (take a look at this page) and perhaps someone with enough knowledge can add (or recompile) the needed WiFi module for the new kernel.

    I will try posting a message at the 99pad forums to see if someone is interested on it.

    Again, thanks for risking your tablet trying it.

  6. #6
    I have also tried the new rom on my m12, and actually works really well.
    What I have found is that the wifi does not work and the screen flips to the opposite side, as you said.
    The USB host function to me either, but I have to try it.
    I hope someone can fix it soon because I have faith again in my tablet

  7. #7
    I sent Astroknight a PM over the 99pad forums, although I don't have much hope he reads it.

    Unfortunately, I haven't been able to post a thread at 99pad due to the verification process that you must fill before posting (I'm already registered there).

    EDIT: I finally achieved to open the thread at 99pad. Let's hope it doesn't get closed because of the links or for being written in English.
    http://www.99pad.com/thread-48286-1-1.html
    Last edited by CoMiKe; 05-25-2012 at 07:41 PM. Reason: Adding a link to the 99pad thread.

  8. #8
    Ok, next things to try.

    Astroknight released an ICS version, but touchscreen was not working.

    Anyway, I believe WiFi worked on that release. If so, it could be possible to extract the WiFi modules from that release and load it into the Arnova firmware.

    There could be problems if kernel versions do not match, but I've read the loading of modules can be forced.

    These pages should prove helpful:
    http://tldp.org/LDP/lkmpg/2.4/html/x49.html
    http://tldp.org/HOWTO/Module-HOWTO/
    Last edited by CoMiKe; 05-27-2012 at 11:45 AM.

  9. #9
    we have seen again the hope for the m12. Does anyone have any news?

  10. #10
    Last Tuesday, I modified the Arnova ROM, adding the WiFi module from the Astroknight ROM and adding also a Terminal Emulator and a root filesystem browser.

    Unfortunately, the WiFi module refused to load through insmod and the logcat and dmesg didn't give any clue about what was failing.

    I also tried to solve the autororation problem using some setprop commands (as suggested on the RK2918 CyanogenMod project), but it didn't work either.

    As of now, the main problem is getting a WiFi module that works on ICS.


 
Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •