PDA

View Full Version : [ROM] Find another ROM for Freelander PD20 Great sku20463



CarriePW
03-19-2013, 08:08 AM
I post another rom for freelander PD20 great sku20463 (http://www.pandawill.com/freelander-pd20-great-version-gps-tablet-pc-7-inch-android-40-12ghz-1gb-ram-8gb-1080p-black-p63134.html) in another post, many members said the files corrupted.
You can try this ROM now.
A777files for PD20 Great sku20463.zip [Download] (www.pandawillforum.com/soft/A777files for PD20 Great sku20463.zip)

Instructions:
Note: there is a video tutorial "视屏刷机教程.avi " in the package , in case something is not easy to understand in video, so I write the instructions as follow.

After download the file, first unpack it,
Note: Please close all anti-virus software in your PC when you download and unpack the package.
Install the VTC driver,
go to 9096---->9097----->9098--->9099--->9100, double click either one of the files in "VTC Driver Installer v5.0.0.3 for x86" to install the VTC drver. (Pls do it in x86 or win7 PC)

Install the usb driver
keep volume+ pressed first , then press on/off button, until the PC find a new device. Then browse the list, find the usb driver and install it.
The usb driver is in 9096-->9097-->9098--> 9101



Upgrade
Note: make sure the tablet has power more than 30%, otherwise it will fail.

go to 9097--->9103 -->9102, double click it to run the FWDN flash tool.

copy the two files 9104 in the folder 9105 to the flahtool.

then turn off the unit. keep the v+ press first, connect it to PC via USB cable, then press on/off button.
release the two buttons when the PC pops up a prompt box. Then Nand data will appear in the Area Map and the tablet screen will light up.

Click "start", it will upgrade automatically. If there is an exception such as red words appear, pls reconnect the unit and flash again.

When it finished, unplug the USB cable, press the on/off button for 5 second to force turn off. Then press on/off again to start the unit. (It will need a longer time to boot up for the first time, please wait patiently)

joemill453
03-19-2013, 09:06 PM
Hello CarriePW so I gave up on trying to get this to work a while ago but this pd20 is collecting dust and Id like to get it working again. The link in this post seems like its another bad link.... I believe one of the reasons were having problems with the files being corrupt is because of the Chinese format(lettering/characters). If you can please change the names of the files and folders to words in English. Now I did everything you said in all of the steps, I can get the files to appear in the FWDN program, I can get the pop up prompt box to appear in FWDN but when the little loading bar on the bottom of that pop up reaches 100% the popup gives the "no boot up file error" and FWDN does not show the NAND storage or anything in the area map box. I believe the main issue is with the drivers and I would like It if you could give me the exact name of what the device should appear as in device manager when it is in the v+ flash mode and connected to the pc.
just to go threw all of the steps the way I did it:
Downloaded the files from http://dl.dropbox.com/u/50683528/FreeLander.rar
installed the VTC driver(I am running a fresh install of windows 7 x86)(ive tryed this on windows xp and still got nowhere)
renamed all of the folders to regular English words.(the Chinese characters mess up all of our programs(winrar, FWDN) because the file location is unreadable)
plugged in the pd20 while holding the v+ when plugged in I pressed the power button until a windows found new hardware screen appeared.
device was not found so i choose to browse my computer for driver, click on let me pick from a list of drivers, then click show all devices, then click "Have Disk"
from there I click browse then slect the usb_driver folder and slect the android_winusb.inf file, then I have the the choice to select: android adb interface, android bootloader interface, android composite adb interface. Ive tryed them all but they do not work. I really feel like it is something driver related because FWDN gives a error like it cannot communicate with the pd20 correctly. Can you please post either another video or be more specifice on what the drivers should be installed as, and the exact steps you took to intall them.
Thank you again for your time and help, Joe

pandox
04-11-2013, 05:57 AM
MY # sku20463 Freelander PD20
jzx.20130226.115512test-keys
NOT WORK correctly...tablet randomly turns off ... ?????..Where could be the problem ..? After turning ..date is always changed on 26.01.2012..?? several times restore factory setting.. but the problem remains... I NEED HELP..

mvesko
05-06-2013, 03:40 PM
I tried all that joemill453 wrote and I also came to the conclusion that the problem is with the drivers. FWDN program can't detect PD20 as a connected device.

I tried lots of different drivers. In this case my Device Manager detected it as "Telechips TCC892x VTC Driver"

Here is the log from FWDN:
============================================
FWDN V7 -- v2.22
============================================

[DEBUG] CFwdnPort::Check_VtcUsbPortChange: \\?\usb#vid_140e&pid_b086#5&6a56ef9&0&6#{db6585b8-0409-4ee6-9636-e595901c59ca} is pluged.
[DEBUG] CFwdnDownload::DeviceArrivalEvent: Device Arrival Event (dev=0)
[DEBUG] CFwdnPort::DEVICE_Ping: FWDN Response Failure
[DEBUG] CFwdnPort::UBS_Ping: UBS Ping : FWDN Response Failure
[DEBUG] CFwdnPort::Load_UBS: Starts (port=0, size=6072)
UBS(USB Boot Supporter) Load Complete! - (0sec 03)
[DEBUG] CFwdnPort::Check_VtcUsbPortChange: \\?\usb#vid_140e&pid_b086#5&6a56ef9&0&6#{db6585b8-0409-4ee6-9636-e595901c59ca} is unpluged.
[DEBUG] CFwdnPort::Check_VtcUsbPortChange: \\?\usb#vid_140e&pid_b086#5&6a56ef9&0&6#{db6585b8-0409-4ee6-9636-e595901c59ca} is pluged.
[DEBUG] CFwdnDownload::DeviceArrivalEvent: Device Arrival Event (dev=0)
[DEBUG] CFwdnPort::DEVICE_Ping: FWDN Response Failure
[DEBUG] CFwdnDownload::Load_BOOT: Starts (device=0)
[DEBUG] CFwdnPort::UBS_InitCodeLoad: InitCode Info : Base=0x82000000, Start=0x8200117C, End=0x820016D4, Size=1368
[DEBUG] CFwdnDownload::Load_BOOT: Base Address=0x82000000
[ERROR] [ERR] ERR_FWDN_UBS_ROM_LOAD_CRC_ERROR
[ERROR] CFwdnPort::FWDN_Normal_Response: FWDN Response Parameter Failure
[DEBUG] CFwdnPort::Check_VtcUsbPortChange: \\?\usb#vid_140e&pid_b086#5&6a56ef9&0&6#{db6585b8-0409-4ee6-9636-e595901c59ca} is unpluged.

danpadure
05-14-2013, 03:22 PM
I belive it's an old firmware, a newer version is required

CarriePW
05-15-2013, 04:28 AM
Sorry!
No newer version right now.

danpadure
05-15-2013, 10:01 AM
There are at least 2 newer firmwares available: 2003.02.02 and 2003.03.13

CarriePW
05-16-2013, 04:26 AM
Sorry! you mean 2013??
I find one in the link (http://223.4.236.214/bbs/showtopic-13607.aspx) is 2012.6

hallowman
05-27-2013, 11:24 PM
my new one has 4.0.4 rom date feb.2013 and its much better then 4.0.3

dexter85
05-29-2013, 08:46 PM
Link is broken!
Can you post new link?

kudlinux
07-12-2013, 02:16 PM
my new one has 4.0.4 rom date feb.2013 and its much better then 4.0.3

could you provide the link to download?

hallowman
07-13-2013, 06:02 PM
could you provide the link to download?
http://goo.gl/0JLp6

kudlinux
07-14-2013, 01:07 PM
http://goo.gl/0JLp6

is this for pd20 great version?

carl0508
08-04-2013, 08:31 PM
I can`t install the usb drivers. Anyone have a solution?